Hunk alloc error fix

View previous topic View next topic Go down

Hunk alloc error fix

Post by Selene on Wed Feb 12, 2014 6:35 am

If you get Hunk alloc error, do the following steps:
1. Start ET, open your console and type:

Code:
/seta com_hunkmegs "192"

2. Go to mods -> jaymod, and repeat.
3. Go to mods -> nq, and repeat again (if the error happened while trying to connect to No Quarter).
4. Exit ET and start it again.
5. Connect to the server.


Last edited by Selene on Wed Feb 12, 2014 7:07 am; edited 2 times in total (Reason for editing : spelling)
avatar
Selene

Posts : 2132
Points : 2906
Join date : 2012-12-13
Age : 25

Back to top Go down

Re: Hunk alloc error fix

Post by manic1965 on Wed Feb 12, 2014 6:40 am

i did start my ET and open my console but it wont let me type anything
avatar
manic1965

Posts : 434
Points : 647
Join date : 2012-10-24
Age : 51
Location : USA,Illinois

Back to top Go down

Re: Hunk alloc error fix

Post by manic1965 on Wed Feb 12, 2014 6:42 am

when i open my console it pops up real fast ( 2-3 seconds ) and then disapears
avatar
manic1965

Posts : 434
Points : 647
Join date : 2012-10-24
Age : 51
Location : USA,Illinois

Back to top Go down

Re: Hunk alloc error fix

Post by LoneStar on Wed Feb 12, 2014 7:28 am

Problem is solved. Discussed it on Teamspeak and fixed. Like a Star @ heaven
avatar
LoneStar

Posts : 862
Points : 881
Join date : 2012-10-28
Age : 51
Location : Tyler,Texas

Back to top Go down

Re: Hunk alloc error fix

Post by manic1965 on Wed Feb 12, 2014 8:04 am

thanks for the help
avatar
manic1965

Posts : 434
Points : 647
Join date : 2012-10-24
Age : 51
Location : USA,Illinois

Back to top Go down

Re: Hunk alloc error fix

Post by GoldenCarrot on Thu Feb 13, 2014 2:28 pm

After /seta com_hunkmeg 192 on both NQ and Jmod I get a Hunk_AllocateTempMemory: Failed on 262200 on Raiders. I`m trying over and over with no luck. Any suggestions?
avatar
GoldenCarrot

Posts : 82
Points : 108
Join date : 2014-01-01
Location : Texas

Back to top Go down

Re: Hunk alloc error fix

Post by GoldenCarrot on Thu Feb 13, 2014 2:47 pm

OK, put the /seta com_hunkmeg 192 in an autoexec.cfg and everything smoothed out just fine. Always the last thing to do works.
avatar
GoldenCarrot

Posts : 82
Points : 108
Join date : 2014-01-01
Location : Texas

Back to top Go down

Re: Hunk alloc error fix

Post by LoneStar on Fri Feb 14, 2014 7:03 am

Strange how that happens Carrot.  Glad you got that fixed. Like a Star @ heaven
avatar
LoneStar

Posts : 862
Points : 881
Join date : 2012-10-28
Age : 51
Location : Tyler,Texas

Back to top Go down

Re: Hunk alloc error fix

Post by -Gotcha- on Fri Feb 14, 2014 9:31 am

This isn't a allocate error but my son is getting a ui_mp_x86.dll Failed Server Check 
When trying to connect to beginner and nq.
Does anyone know how to fix this problem without reinstalling wolf?
avatar
-Gotcha-

Posts : 404
Points : 491
Join date : 2013-11-23
Age : 34
Location : Michigan

Back to top Go down

Re: Hunk alloc error fix

Post by -Gotcha- on Fri Feb 14, 2014 9:34 am

does anyone know how to fix this problem without reinstalling wolfenstein
avatar
-Gotcha-

Posts : 404
Points : 491
Join date : 2013-11-23
Age : 34
Location : Michigan

Back to top Go down

Re: Hunk alloc error fix

Post by Selene on Fri Feb 14, 2014 12:04 pm

Run ET.exe in compability mode with win XP Sp3 and check "run always as administrator".
avatar
Selene

Posts : 2132
Points : 2906
Join date : 2012-12-13
Age : 25

Back to top Go down

Re: Hunk alloc error fix

Post by -Gotcha- on Fri Feb 14, 2014 1:02 pm

Yea i thought i did that to both but only to mine.
Thanks Selene
avatar
-Gotcha-

Posts : 404
Points : 491
Join date : 2013-11-23
Age : 34
Location : Michigan

Back to top Go down

Re: Hunk alloc error fix

Post by CowboyUp on Thu Jan 22, 2015 6:28 pm

Tried Selene's fix, but I'm still getting this message on the new Arctic Guns map.  It says that it will change on restart, but still get the message every time.

Other ideas?  Bear in mind, I pretty much need step by step instructions.  If you tell me to go to my whrfluxum and vent it, then just u7nre-start using the roxcjsqi then you've lost me.
avatar
CowboyUp

Posts : 143
Points : 179
Join date : 2011-10-30
Location : Louisiana

Back to top Go down

Re: Hunk alloc error fix

Post by Selene on Fri Jan 23, 2015 2:48 am

Maybe go even higher and use 256. I'm using this setting. I'm sure your graphics card has more memory than 256 MB, so you can use it to make your experience better.

Also make sure you do it both under etmain AND jaymod. Doing it just under etmain will not change your config on jaymod.
avatar
Selene

Posts : 2132
Points : 2906
Join date : 2012-12-13
Age : 25

Back to top Go down

Re: Hunk alloc error fix

Post by Guest on Fri Mar 20, 2015 12:21 am

For anyone that still gets the error message even after setting the values you can try this method also.  

Locate the Shortcut you use to start Enemy Territory
1. Right click the shortcut
2. Click Properties
3. Locate the Line that says Target
- It will look similar to this, 
Code:
"C:\Program Files (x86)\Wolfenstein - Enemy Territory\et.exe"


Now click in that box and go to the end, then add this to the end of the line,


Code:
+set com_hunkmegs 256

The end result will be this

Code:
"C:\Program Files (x86)\Wolfenstein - Enemy Territory\et.exe" +set com_hunkmegs 256

Make sure you have a space between the " and the +

Doing it this way should avoid the problem where ET refuses to save your config because you have to set it so many times in so many ways for it to work correctly.

Guest
Guest


Back to top Go down

Re: Hunk alloc error fix

Post by CowboyUp on Tue Mar 24, 2015 6:47 pm

Selene's comment about using 256 solved my problem immediately.
avatar
CowboyUp

Posts : 143
Points : 179
Join date : 2011-10-30
Location : Louisiana

Back to top Go down

Re: Hunk alloc error fix

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum