ui_mp_x86.dll failed

View previous topic View next topic Go down

ui_mp_x86.dll failed

Post by jonoconor on Sat Oct 06, 2012 1:43 pm

I tried to get on to the Sniper server and got the 'ui_mp_x86.dll failed' error. So I followed instructions I found on an ET site and uninstalled/reinstalled ET. Did it all as instructed and now I get the ddl failed error on the Beginner server and a 'wrong version of ET' error on Sniper. Sad Is there a forum and post here that describes how to get this right? Much obliged.

Beavis and Friedrich, I guess this is your chance to get rid of me once and for all.Twisted Evil

jono
avatar
jonoconor

Posts : 19
Points : 23
Join date : 2012-09-16
Location : Victoria, BC Canada

Back to top Go down

Re: ui_mp_x86.dll failed

Post by obituary on Sat Oct 06, 2012 4:25 pm

What operating system are you using? If Windows 7, try running as an administrator.

If you are running a Mac, use this link to update your client so it will work on silent mod: http://www.mrbass.org/enemyterritory/

If that doesn't work, you may have visited another server and gotten a modified client file If this is the case, try deleting your "silent" folder and see if that helps. That would force our server to re-download everything to you fresh.

_________________
The time you enjoy wasting is not wasted time.
avatar
obituary

Posts : 3494
Points : 4814
Join date : 2011-05-15

Back to top Go down

Re: ui_mp_x86.dll failed

Post by jonoconor on Sat Oct 06, 2012 9:13 pm

Thanks, obi. I'm on Windoze 7 and running as admin got me into the Beginner server. I had deleted the entire ET directory from Program Files after the uninstall, so I had no silent folder to worry about.

Next question: I get the 'Protocol mismatch between Client and Server' error message on trying to connect to the new Sniper server. Is there a way to be able to connect to both the Beginner and Sniper servers with the same version? I installed the standard ET 2.55 with no updates.
avatar
jonoconor

Posts : 19
Points : 23
Join date : 2012-09-16
Location : Victoria, BC Canada

Back to top Go down

Re: ui_mp_x86.dll failed

Post by obituary on Sat Oct 06, 2012 11:32 pm

Beginner is running on a server that accepts both 2.55 and 2.60. Sniper will only accept 2.60 for now. You should google the ET 2.60 patch and install it.

_________________
The time you enjoy wasting is not wasted time.
avatar
obituary

Posts : 3494
Points : 4814
Join date : 2011-05-15

Back to top Go down

Re: ui_mp_x86.dll failed

Post by jonoconor on Sun Oct 07, 2012 12:35 am

Cool. Thanks, I'll do it. I was worried that it was one or the other.

jono
avatar
jonoconor

Posts : 19
Points : 23
Join date : 2012-09-16
Location : Victoria, BC Canada

Back to top Go down

Re: ui_mp_x86.dll failed

Post by jonoconor on Sun Oct 07, 2012 1:07 am

Sorry if I'm becoming a bit of a PITA here, but which 2.60 patch(es) do I need for the FBY servers? Fileplanet has 2.60 and 2.60b. I assume the 'b' patch includes all the old 2.60 stuff plus more updates, but not sure. They also have a patch-switcher for toggling back and forth from 2.60 for most servers and 2.60b for etpro servers, but I'm a bit hesitant about introducing any possibility of screwup.

Thx,

jono
avatar
jonoconor

Posts : 19
Points : 23
Join date : 2012-09-16
Location : Victoria, BC Canada

Back to top Go down

Re: ui_mp_x86.dll failed

Post by obituary on Sun Oct 07, 2012 8:43 am

It goes like this:



ET 2.55 is default install

2.56

2.60 (includes 2.56 so you don't need 2.56)

2.60b (just replaces ET.exe and ETDED.exe)

2.60d (for Macs)

I'm not sure if there are 2.57-2.59 patches, never seen them.

Also I do not know if there is a 2.60c patch, again i have never seen it or heard of anyone needing it.

FBY has two different server hosts. One has extra programs they install that lets us run on 2.55 and 2.60 master list simultaneously. The other is just on 2.60 for now (I'm looking at installing the patch that gives you dual master lists but I need to work with it a bit before I feel comfortable with it on a live server).



Hope that clarifies things lol.

_________________
The time you enjoy wasting is not wasted time.
avatar
obituary

Posts : 3494
Points : 4814
Join date : 2011-05-15

Back to top Go down

Re: ui_mp_x86.dll failed

Post by jonoconor on Sun Oct 07, 2012 2:18 pm

You da man!! I installed 2.60b. Took all of one minute to find and install. Now I can connect to Beginner, Sniper and Flight School. We need to encourage more players to check out Sniper and Flight School. Great servers.

I've been using GameTracker Lite to manage my server connections. Seems to work well. Free and you don't have to wade through a bunch of servers or type anything to connect.



Thx,

jono
avatar
jonoconor

Posts : 19
Points : 23
Join date : 2012-09-16
Location : Victoria, BC Canada

Back to top Go down

Re: ui_mp_x86.dll failed

Post by Noname(Est) on Mon Oct 08, 2012 4:14 am

lol jono actually i made a post about this error because i have seen so many people with this bug also happend to me when got a new pc with w7
avatar
Noname(Est)

Posts : 465
Points : 469
Join date : 2011-05-16
Age : 26
Location : Estonia/Tallinn

Back to top Go down

Re: ui_mp_x86.dll failed

Post by Kernel26 on Mon Oct 08, 2012 8:41 pm

Also note that the 2.60b update for Linux will cause you headaches if you play True Combat:Elite mod.

Kernel26
Guest


Back to top Go down

Re: ui_mp_x86.dll failed

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum